How to compile ettercap NG 0.7.3 on Mac OSX when you get that annoying pthread error

August 10, 2007

[Update]: If you’re trying to compile Ettercap on Leopard, check here.

I’ve been trying to get this compiled for 2 days now, finally found out how to do it. Figured I’d share for everyone else.

If you try this without making the change to the configure file it will complain about you not having support for pthreads, so here’s what you do:

Open the configure script, search for the line that say something like "$OS" != "MACOSX", you need to change this line to say "$OS" != "DARWIN", voila!
./configure && make && make install away! Enjoy ettercap!

Now if I could only get dsniff working as well… :-/

posted in ettercap, mac, networking, osx, security by Lee

16 Comments to "How to compile ettercap NG 0.7.3 on Mac OSX when you get that annoying pthread error"

  1. Fabio Franconeri wrote:

    Thanks for the trick.. I was simply using Gcc-4 got from fink as compiler setting CC=/sw/bin/gcc-4

    Still I get an error in the ./configure script saying
    configure: error: libnet >= not found

    I tried to get updated version of libnet from fink too but can’t seem to make it recognizi it.
    Do you know how to get rid of that error??

    Thanks a lot.

  2. Lee Hinman wrote:

    You could always try building libnet from source instead of fink. I’ve found that if you’re going to mix-and-match libraries and programs from Fink and source, it’s best to either do the program and ALL the libraries from source, or the programs and ALL the libraries from fink.

    In the fink case, fink install ettercap works great if you just need to binary installed without a lot of hassle.

  3. Tupring wrote:

    Thanks, I never would have figured that out!

  4. Compile Ettercap-NG-0.7.3 natively on Leopard Fix « :wq wrote:

    […] 15, 2007 · No Comments This is a continuation of the pthread error that I mentioned in a previous […]

  5. Kwint wrote:

    I did the editing trick and the configuration seems to be ok. but even “make” or “make install” don’t work. I have this error

    “XXXe:ettercap-NG-0.7.3 me$ makemake: *** No targets specified and no makefile found. Stop.
    XXX:ettercap-NG-0.7.3 me$ ”

    any idea?

  6. Lee wrote:

    Did you run ./configure first? ./configure will generate a Makefile for you.

  7. Kwint wrote:

    ya i didi it, and everything seems to be ok.

  8. Kwint wrote:

    I just did it again. Unzip

    cd /passtomyettercap folder

    I didn’t had the PHTREAD error cause I corrected it with the trick.


    make or make install

    I also tried sudo make or sudo make install but… :

    “make: *** No targets specified and no makefile found. Stop.

  9. Kwint wrote:

    Hi all.

    I ‘m trying to get Ettercap running on my 10.5.8.
    I used to have the PTHREAD Error and managed it with your trick.

    Now I have a different cool new problem. I can’t “MAKE” or “MAKE INSTALL”.

    Here it’s the message I have on the ending line :

    “checking for libnet… no
    configure: error: libnet >= not found”

    I’m using MacPorts to manage my ports and libs.
    So I Unistall it and Reistall everyting.

    Here it’s my ports list from “port installed” command :

    “The following ports are currently installed:
    autoconf @2.64_2 (active)
    automake @1.11_0 (active)
    expat @2.0.1_0 (active)
    gettext @0.17_4 (active)
    gperf @3.0.4_0 (active)
    help2man @1.36.4_1 (active)
    libiconv @1.13_0 (active)
    libnet11 @1.1.4_0 (active)
    libpcap @1.0.0_0 (active)
    libtool @2.2.6a_0 (active)
    m4 @1.4.13_0 (active)
    ncurses @5.7_0 (active)
    ncursesw @5.7_0 (active)
    p5-locale-gettext @1.05_0 (active)
    perl5 @5.8.9_0 (active)
    perl5.8 @5.8.9_3 (active)
    pkgconfig @0.23_1 (active)
    xorg-libpthread-stubs @0.1_0 (active)
    zlib @1.2.3_3 (active)”

    So I obviously Have Libnet Installed.

    Any idea what my problem is ?

  10. Kwint wrote:

    OK… so.

    I’ve manage to install ettercap through MacPorts. So i launched it “eetercap -C” and selected “Sniff>Unified Sniffing”…

    Here Ettercap Crashe and here the message I have :

    “ERROR : 13, Permission denied

    pcap_lookupdev: no suitable device found”

    Any idea ?

    thx all

  11. Christoph Murauer wrote:

    Hy !

    I know that this posts are old but maybe someone is interesting …

    First, Lee thanks for your help with snort … in the meantime I build all things from source without homebrew (even it works fine).

    I run ettercap on Mac OS X 10.7 Lion with Xcode 4.1 … if someone is interested there are more things to do.

    To the above … before to compile ettercap itself – you have to compile libnet (it was really hard to find the right one) and pcre and then ettercap (with path to pcre because it is not there where configure looks for it).

    @Kwint : sudo ettercap -C … then it works.

  12. weight loss wrote:

    Very excellent thought! This is the best post in your site. I think visitor get more effective info in this post. Thanks :)

  13. sk0rp10 wrote:

    @Christoph: could you please post the full instructions on how to compile ettercap @ OSX Lion?
    I’m stuck at pthread not found error while configuring ettercap before Make.

    Thank you!

  14. Basti wrote:

    Hoepfully anyone could help me out with this…
    FIRST: WOOOHOOOW I would never figured out that issue ! Thanks a lot…Buttttt still:
    ./configure = check
    make = check
    make install = error >.<

    collect2: ld returned 1 exit status
    make[2]: *** [ettercap] Error 1
    make[1]: *** [all-recursive] Error 1
    make: *** [all-recursive] Error 1

    hopefully this last 4 lines are enough for giving me an answer on what to do :/

    thanks a lot

  15. wino wrote:

    Basti. sudo su. then type it again..

  16. Basti wrote:

    thanks, never thought I would get an answer… I’m going to try this the next days…

Powered by Wordpress and MySQL. Theme by Shlomi Noach,